Page 1 of 1

SQL error when posting in BL - Products and Events

PostPosted: Mon Dec 11, 2017 1:36 pm
by Erunanion
Hi all,

I thought I ought to post this, as I've encountered this error when trying to post in the Black Library - Products and Events forum. Evidently it isn't affecting the entire forum, since I've been able to post this. I've also dropped an email to the admin inbox.

Error message:

General Error
SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x99\x82[/...' for column 'post_text' at row 1 [1366]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.

Re: SQL error when posting in BL - Products and Events

PostPosted: Mon Dec 11, 2017 10:50 pm
by Xisor
Hmm, that is vexing. I've not had a chance to examine it in proper depth, but a couple of years have shown:
- whatever the issue is, it's not impacting on me (as I tried to explore it)
- internet searching for answers suggests it might be to do with including emoji (as opposed to smilies :ugeek: ).
- indeed, trying that with an emoji in gets the error, but without lets me post

Hypothetical: your post included some unusual characters (e.g. emoji)?

Re: SQL error when posting in BL - Products and Events

PostPosted: Tue Dec 12, 2017 4:23 pm
by schaferwhat‽
part of me thinks the theme is the issue. Like how it has broken spoilertags because we have various nonstandard things interacting together well.

Re: SQL error when posting in BL - Products and Events

PostPosted: Tue Dec 12, 2017 7:58 pm
by Erunanion
Ah, I think that is it. Gav's article included an emoji, and evidently what's causing the issue. Many thanks guys!