SQL error when posting in BL - Products and Events

An area for Bolthole-related business, such as technical issues, moderation consultation and any Bolthole-related topics.

SQL error when posting in BL - Products and Events

Postby Erunanion » Mon Dec 11, 2017 1:36 pm

Hi all,

I thought I ought to post this, as I've encountered this error when trying to post in the Black Library - Products and Events forum. Evidently it isn't affecting the entire forum, since I've been able to post this. I've also dropped an email to the admin inbox.

Error message:

General Error
SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x99\x82[/...' for column 'post_text' at row 1 [1366]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.
Check out my shiny new website, with genuine new-blog smell! - http://www.jonathandbeer.com

The Emperor's Mercy - Prologue - The first piece of fiction I've put up on the Bolthole's new incarnation.

"It is the 41st Millennium, and never underestimate the ability of the universe to infinitely screw you over." - Lord Lucan
Erunanion
 
Posts: 387
Joined: Sun Mar 06, 2011 5:10 pm


Re: SQL error when posting in BL - Products and Events

Postby Xisor » Mon Dec 11, 2017 10:50 pm

Hmm, that is vexing. I've not had a chance to examine it in proper depth, but a couple of years have shown:
- whatever the issue is, it's not impacting on me (as I tried to explore it)
- internet searching for answers suggests it might be to do with including emoji (as opposed to smilies :ugeek: ).
- indeed, trying that with an emoji in gets the error, but without lets me post

Hypothetical: your post included some unusual characters (e.g. emoji)?
"When my housemate puts his bike in the middle of the living room floor, I find that inordinately jarring, annoying and rude, but for me to refer to it as "genocide" would be incorrect." -Ath
xisor.wordpress
Xisor's Dice-o-matic Maiminator
User avatar
Xisor
Site Admin
 
Posts: 4955
Joined: Thu Mar 03, 2011 10:13 pm
Location: Canterbury


Re: SQL error when posting in BL - Products and Events

Postby schaferwhat‽ » Tue Dec 12, 2017 4:23 pm

part of me thinks the theme is the issue. Like how it has broken spoilertags because we have various nonstandard things interacting together well.
User avatar
schaferwhat‽
 
Posts: 2887
Joined: Thu Mar 03, 2011 11:25 pm
Location: Behind your eyes looking out in terror.


Re: SQL error when posting in BL - Products and Events

Postby Erunanion » Tue Dec 12, 2017 7:58 pm

Ah, I think that is it. Gav's article included an emoji, and evidently what's causing the issue. Many thanks guys!
Check out my shiny new website, with genuine new-blog smell! - http://www.jonathandbeer.com

The Emperor's Mercy - Prologue - The first piece of fiction I've put up on the Bolthole's new incarnation.

"It is the 41st Millennium, and never underestimate the ability of the universe to infinitely screw you over." - Lord Lucan
Erunanion
 
Posts: 387
Joined: Sun Mar 06, 2011 5:10 pm


Return to Board index

Return to About the Bolthole

Who is online

Users browsing this forum: No registered users and 2 guests